FANDOM


When you download LiveCode, you download a fantastic IDE for developing programs. It contains a lot of features that will be shown here.

This is the development toolbar:

DevelopmentToolbar

Development toolbar

it is where you launch all tools for creating you application. If you don't need it, but you want just to run your application, go to Development->Suspend Development tools and you'll obtain this:

RestoreDevelpmentTools

Restore development tools


Push the button to show again the development tools.

User guideEdit

Going to Help->User Guide, you'll launch a PDF user guide of 378 pages!

LiveCodeGuide

LiveCode Guide PDF

You may also read it here: http://www.scribd.com/doc/216789127/LiveCode-userguide

Additional helpEdit

You can also go to:

  • User samples
  • Tutorials
  • Resource
  • Dictionary

using the following buttons:

HelpDevelopmentToolbar

User samplesEdit

This part of the program shows you other user scripts, which you can downland and see the source to. You can also rate scripts or upload your scripts.

UserSamples


TutorialsEdit

This launches the browser to the LiveCode tutorial website: http://lessons.runrev.com/

Tutorials

ResourcesEdit

This launches a script containing many examples and tutorials:

ResourceCenter

DictionaryEdit

This launches an interactive dictionary, which explains every command in LiveCode. It also shows what is available by platform, and shows you examples. You can upload your comments or examples as well.

Dictionary

My first programEdit

This short article will show you how to create a simple program.

First of all activate the tools palette if not already on the screen.

Go to Tools->Tool Palette. A window like this will appear:

ToolsPalette

It has two button, the pointer tool and the browse tool to switch to edito mode to use mode. So You don't need to compile, just a click and you see how your program works.

Then go to  File->New Mainstack and a clear window will appear like this:

Untitled

Now Drag and drop a button in the window like this:

Untitled2

Right click on the button and click on Edit Script menu item, the Code editor will appear:

Code editor

Add the following code and save:

on mouseUp
  answer "Hello world!"
end mouseUp

Now go to Tools->Browse tool and click on you button, the program will work and it will pop up another window with Hello world!

Untitled3

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.